Commit d66482bd authored by Chris's avatar Chris
Browse files

Rename OS spceific task files

Instead of being postfixed with '_' followed by an identifier, OS specific files
will now be postfixed with '.' followed by an identifier.
parent 0303d82c
......@@ -29,10 +29,10 @@
- name: Include OS specific bootstrap tasks
include_tasks: '{{ item }}'
with_first_found:
- tasks/bootstrap_{{ ansible_distribution | lower }}-{{ ansible_distribution_version | lower }}.yml
- tasks/bootstrap_{{ ansible_distribution | lower }}-{{ ansible_distribution_release | lower }}.yml
- tasks/bootstrap_{{ ansible_distribution | lower }}-{{ ansible_distribution_major_version | lower }}.yml
- tasks/bootstrap_{{ ansible_distribution | lower }}.yml
- tasks/bootstrap_{{ ansible_os_family | lower }}.yml
- tasks/bootstrap.{{ ansible_distribution | lower }}-{{ ansible_distribution_version | lower }}.yml
- tasks/bootstrap.{{ ansible_distribution | lower }}-{{ ansible_distribution_release | lower }}.yml
- tasks/bootstrap.{{ ansible_distribution | lower }}-{{ ansible_distribution_major_version | lower }}.yml
- tasks/bootstrap.{{ ansible_distribution | lower }}.yml
- tasks/bootstrap.{{ ansible_os_family | lower }}.yml
...
# vi: set ts=2 sts=2 sw=2 et ft=yaml:
......@@ -29,11 +29,11 @@
# Install common packages and utils
- include_tasks: '{{ item }}'
with_first_found:
- tasks/install-common-utils_{{ ansible_distribution | lower }}-{{ ansible_distribution_version | lower }}.yml
- tasks/install-common-utils_{{ ansible_distribution | lower }}-{{ ansible_distribution_release | lower }}.yml
- tasks/install-common-utils_{{ ansible_distribution | lower }}-{{ ansible_distribution_major_version | lower }}.yml
- tasks/install-common-utils_{{ ansible_distribution | lower }}.yml
- tasks/install-common-utils_{{ ansible_os_family | lower }}.yml
- tasks/install-common-utils.{{ ansible_distribution | lower }}-{{ ansible_distribution_version | lower }}.yml
- tasks/install-common-utils.{{ ansible_distribution | lower }}-{{ ansible_distribution_release | lower }}.yml
- tasks/install-common-utils.{{ ansible_distribution | lower }}-{{ ansible_distribution_major_version | lower }}.yml
- tasks/install-common-utils.{{ ansible_distribution | lower }}.yml
- tasks/install-common-utils.{{ ansible_os_family | lower }}.yml
...
# vi: set ts=2 sts=2 sw=2 et ft=yaml:
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment